Resolved
New invitations works as desired now.
Investigating
We're aware of an issue where newly invited users cannot sign in after accepting their invitation.
Existing users and accounts are not affected.
Our team is investigating the cause and will provide an update soon.