Back
Resolved

Google Sheets Integrations Degraded Performance

Started 12 Sep at 04:00pm CEST.

Integrations
Created

We’re currently experiencing degraded performance issues with the Google Sheets Integration. Our team is currently working to restore normal performance levels. All responses will be delivered to integrated Google Sheets with a delay. We apologize for the inconvenience caused.

Posted 12 Sep at 04:00pm CEST.