Back to overview
Downtime

Survicate Panel is inaccessible

Apr 06 at 01:20pm CEST
Affected services
Web application

Resolved
Apr 06 at 01:44pm CEST

The issue with accessing panel.survicate.com has been resolved.

Created
Apr 06 at 01:20pm CEST

We are currently experiencing issues with accessing panel.survicate.com. We are working on resolving the issue as soon as possible.