Back
Maintenance

Feedback Hub Maintenance

Completed 13 Nov at 01:00pm CET.

Feedback Hub
Completed

Posted 13 Nov at 01:00pm CET.
Started

On the 13th of November at 12 AM CET, there will be a scheduled maintenance of Feedback Hub, during which the service will not be available.

During this maintenance window, the Survicate panel will be accessible, and all surveys will be active.

We appreciate your patience and understanding. As always, if you have questions or issues, feel free to contact us via Intercom chat.

Posted 13 Nov at 12:00pm CET.