Back to overview
Degraded

Delays in receiving responses

Jan 07 at 02:24pm CET
Affected services
Email & shareable link surveys
Website or in-product surveys
Mobile app surveys

Resolved
Jan 07 at 06:47pm CET

The issue has been resolved.

Created
Jan 07 at 02:24pm CET

We are currently experiencing delays in responses coming to the Analyze tab due to the high load on our servers. The responses may come with an hour delay.