Back
Maintenance

Feedback Hub Maintenance

Completed 12 Mar at 02:00pm CET.

Feedback Hub
Completed

Posted 12 Mar at 02:00pm CET.
Started

On the 12th of March at 12 AM CET, there will be a scheduled maintenance of Feedback Hub, during which the service will not be available.

During this maintenance window, the Survicate panel will be accessible, and all surveys will be active.

We appreciate your patience and understanding. As always, if you have questions or issues, feel free to contact us via Intercom chat.

Posted 12 Mar at 12:00pm CET.