Back
Maintenance

Maintenance of Intercom Messenger surveys

Completed 11 Jun at 01:00pm CEST.

Intercom Messenger surveys
Completed

Posted 11 Jun at 01:00pm CEST.
Started

Please be aware that we are going to have a scheduled maintenance of Intercom app surveys. It will take place on Saturday, June 11th, from 12 pm CET to 13 pm CET. During this time any work with Intercom Messenger surveys will be unavailable.

We appreciate your patience and understanding. As always, if you have any questions or issues feel free to contact us via Intercom chat.

Posted 11 Jun at 12:00pm CEST.