Survicate

Panel Loading Degradation
Resolved·Degraded performance

The issue causing slow loading times of the Survicate panel has been resolved. We're very sorry for the inconvenience and your patience while we worked to restore full functionality.

Wed, Nov 5, 2025, 11:54 AM
(1 month ago)
·
Affected components
Integrations
Web application
Insights Hub
Research Assistant
Updates

Resolved

The issue causing slow loading times of the Survicate panel has been resolved. We're very sorry for the inconvenience and your patience while we worked to restore full functionality.

Wed, Nov 5, 2025, 11:54 AM

Investigating

We’re currently experiencing degraded performance in the Survicate panel. The panel does load, but significantly slower than usual.

Our team is already aware of the root cause and is working on restoring normal performance. We’ll share updates as soon as we have more information.

Thank you for your patience and understanding 🙏

Wed, Nov 5, 2025, 11:04 AM(49 minutes earlier)