Resolved
The Google Sheets integration is fully operational now.
Identified
The Google Sheets integration is currently experiencing degraded performance. Survey data may take longer than usual to sync to Google Sheets. We expect the delay to be resolved within approximately 12 hours.
We will post an update once the issue is resolved.