Feedback Hub maintenance
Incident Report for Survicate
Resolved
This incident has been resolved.
Posted Jul 09, 2019 - 16:46 UTC
Monitoring
We are currently making some changes in Feedback Hub making searching notes and tagging them inaccessible. All integrated sources are operational, and notes are being collected. We will close this issue as soon as it's resolved.
Posted Jul 09, 2019 - 15:52 UTC
This incident affected: Feedback Hub.