All emails sent from Survicate will be delivered with a delay
Incident Report for Survicate
Resolved
The issue has been resolved.
Posted Oct 21, 2020 - 10:59 UTC
Identified
We're currently unable to deliver emails in real-time. The issue may affect email notifications, survey reports, password recovery communication, and user invitations. No data will be lost. All emails will be delivered with a delay. Our development team is currently investigating the issue and will keep you updated.
Posted Oct 20, 2020 - 21:22 UTC
This incident affected: Web application.