Surveys degraded performance
Incident Report for Survicate
Resolved
The incident has been resolved.
Posted Mar 18, 2020 - 09:52 UTC
Identified
We're currently experiencing a degraded performance of all surveys. Web & mobile surveys might display with a delay. Survey pages might load longer than usual. Survey preview in web application is also not available. We're working to resolve the issue.
Posted Mar 18, 2020 - 09:40 UTC
This incident affected: Surveys (Link Surveys, Intercom Messenger App Surveys, Website Surveys, Mobile Surveys) and Web application.