Survicate Panel Unavailable
Incident Report for Survicate
Resolved
Survicate Web Application is operational. We're sorry for inconvenience.
Posted Jan 31, 2019 - 15:45 UTC
Identified
We're currently reverting a product update that made Survicate panel inaccessible. All survey-related features are operational. All surveys are operational, data collected with those surveys will be stored.

We're sorry for inconvenience.
Posted Jan 31, 2019 - 15:27 UTC
This incident affected: Web application.