Contact form question not appearing on some surveys
Incident Report for Survicate
Resolved
The issue has been resolved, all surveys are fully operational.
Posted Jul 09, 2020 - 15:46 UTC
Identified
We've identified an issue, causing contact forms question to not appear on some surveys. We're currently working to resolve the issue.
Posted Jul 09, 2020 - 15:33 UTC
This incident affected: Surveys (Link Surveys, Website Surveys, Mobile Surveys).