Back
Degraded

Google Sheets Integrations Degraded Performance

Started 12 Aug at 10:00am CEST, resolved 13 Aug at 08:00pm CEST.

Integrations
Resolved

All answers have been sent to Google Sheets. The Google Sheet integration is now operating at regular performance.

Posted 13 Aug at 08:00pm CEST.
Created

We’re currently experiencing degraded performance issues with the Google Sheets Integration. Our team is currently working to restore normal performance levels. All responses will be delivered to integrated Google Sheets with a delay. We apologize for the inconvenience caused.

Posted 12 Aug at 10:00am CEST.