Unable to create surveys on Safari
Incident Report for Survicate
Resolved
The issue has been fixed and everything is confirmed to work correctly.
Posted May 12, 2020 - 09:27 UTC
Investigating
We've identified an issue preventing Safari users from creating surveys. We're working to fix the problem.
Posted May 11, 2020 - 21:55 UTC
This incident affected: Web application.