Surveys degraded performance
Incident Report for Survicate
Resolved
The incident has been resolved.
Posted Mar 17, 2020 - 16:01 UTC
Identified
We're currently experiencing a degraded performance of all surveys. Web & mobile surveys might display with a delay. Survey pages might load longer than usual. We're working to resolve the issue.
Posted Mar 17, 2020 - 15:41 UTC
This incident affected: Surveys (Link Surveys, Intercom Messenger App Surveys, Website Surveys, Mobile Surveys).